西维蜀黍

【PVE】Install ProxMox VE (PVE)

Download

https://www.proxmox.com/en/downloads

Prepare a USB Flash Drive

  • use balenaEtcher
  ...


【macOS】制作 VMware vSphere Hypervisor (ESXi) 8.0 U3

Install

$ diskutil list

$ diskutil eraseDisk MS-DOS "ESXI" MBR /dev/disk4

$ diskutil unmountDisk /dev/disk4

$ sudo fdisk -e /dev/disk4
Password:
fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory
Enter 'help' for information
fdisk: 1> f 1
Partition 1 marked active.
fdisk:*1> write
Writing MBR at offset 0.
fdisk: 1> exit

$ hdiutil mount Downloads/VMware-VMvisor-Installer-8.0U3-24022510.x86_64.iso
/dev/disk6          	                               	/Volumes/ESXI-8.0U3-24022510-STANDARD
$ cp -R /Volumes/ESXI-8.0U3-24022510-STANDARD/* /Volumes/ESXI/
  ...


【Compile】ANTLR

Background 文法定义(Grammar Definition) 风控策略表达式的语法到底是什么样的?也就是说 风控策略表达式这种DSL的语法结构是什么? 在学习   ...


【Compile】Lex and Yacc

Lex

Lex is a computer program that generates lexical analyzers (“scanners” or “lexers”). It is commonly used with the yacc parser generator and is the standard lexical analyzer generator on many Unix and Unix-like systems.

Lex reads an input stream specifying the lexical analyzer and writes source code which implements the lexical analyzer in the C programming language.

  ...


【Compile】编译(Compilation)

编译原理(Fundamentals of Compiling)

  ...